The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.
via cve_org
| Version | Type | Source | Base | Exp | Imp |
|---|---|---|---|---|---|
| 3.1 | Primary | NVD | 7.7 | 1.8 | 5.3 |
| 3.1 | Secondary | GHSA | 9.8 | — | — |
| 4.0 | Primary | cve.org | 7.2 | — | — |
| 4.0 | Secondary | GHSA | 7.2 | — | — |
| 4.0 | Secondary | ENISA EUVD | 7.2 | — | — |
| 4.0 | Secondary | NVD | 7.2 | — | — |